Pleo supports the latest two versions of the following browsers: 

  • Chrome
  • Firefox
  • Safari
  • Microsoft Edge

Pleo will stop supporting Microsoft Internet Explorer as of May 1st, 2019.

If you are currently using Pleo on Internet Explorer, we highly recommend you to install and start using one of our supported browsers as mentioned above.

Did this answer your question?